Logbot fails to make new folder when invited to new room #4

Closed
opened 9 months ago by decentral1se · 2 comments
Owner

Maybe a permissions issue on the server? Not sure.

INFO     Joining xxx@xxx.xxx.xxx as invited
ERROR    Bot.group threw exception: [Errno 2] No such file or directory: '/var/www/logs/xxx/images'
Traceback (most recent call last):
  File "/srv/gitea/clones/bots/.venv/lib/python3.7/site-packages/xbotlib.py", line 645, in group_message
    self.group(message)
  File "logbot.py", line 131, in group
    media_post, media_type = download(self, message)
  File "logbot.py", line 55, in download
    os.mkdir(path)
FileNotFoundError: [Errno 2] No such file or directory: '/var/www/logs/xxx/images'
Maybe a permissions issue on the server? Not sure. ``` INFO Joining xxx@xxx.xxx.xxx as invited ERROR Bot.group threw exception: [Errno 2] No such file or directory: '/var/www/logs/xxx/images' Traceback (most recent call last): File "/srv/gitea/clones/bots/.venv/lib/python3.7/site-packages/xbotlib.py", line 645, in group_message self.group(message) File "logbot.py", line 131, in group media_post, media_type = download(self, message) File "logbot.py", line 55, in download os.mkdir(path) FileNotFoundError: [Errno 2] No such file or directory: '/var/www/logs/xxx/images' ```
Poster
Owner

as a quick fix, you could make that folder for now

> as a quick fix, you could make that folder for now
Poster
Owner

After creating the folder that was missing, I now get the following:

ERROR    Bot.group threw exception: 'xxx@xxx.xxx.xxx'
Traceback (most recent call last):
  File "/srv/gitea/clones/bots/.venv/lib/python3.7/site-packages/xbotlib.py", line 645, in group_message
    self.group(message)
  File "logbot.py", line 133, in group
    add_to_db(self, message, media_post=media_post)
  File "logbot.py", line 9, in add_to_db
    keys = [x for x in self.db[message.room]['messages'].keys()]
KeyError: 'xxx@xxx.xxx.xxx'
After creating the folder that was missing, I now get the following: ``` ERROR Bot.group threw exception: 'xxx@xxx.xxx.xxx' Traceback (most recent call last): File "/srv/gitea/clones/bots/.venv/lib/python3.7/site-packages/xbotlib.py", line 645, in group_message self.group(message) File "logbot.py", line 133, in group add_to_db(self, message, media_post=media_post) File "logbot.py", line 9, in add_to_db keys = [x for x in self.db[message.room]['messages'].keys()] KeyError: 'xxx@xxx.xxx.xxx' ```
decentral1se self-assigned this 9 months ago
decentral1se closed this issue 9 months ago
Sign in to join this conversation.
No Label
No Milestone
No Assignees
1 Participants
Notifications
Due Date

No due date set.

Dependencies

This issue currently doesn't have any dependencies.

Loading…
There is no content yet.